React Native version mismatch.

have been encountering a lot “react native version mismatch” isuse:


console.error: "React Native version mismatch.

JavaScript version: 0.59.8
Native version: 0.57.1

Make sure that you have rebuilt the native code. If the problem persists try clearing the Watchman and packager caches with `watchman watch-del-all && react-native start --reset-cache`."
checkVersions
AppEntry.bundle?platform=android&dev=true&minify=false&hot=false&assetPlugin=%2FUsers%2Flwpro2%2FProjects%2FRoomChat%2Fnode_modules%2Fexpo%2Ftools%2FhashAssetFiles.js:24672:20

AppEntry.bundle?platform=android&dev=true&minify=false&hot=false&assetPlugin=%2FUsers%2Flwpro2%2FProjects%2FRoomChat%2Fnode_modules%2Fexpo%2Ftools%2FhashAssetFiles.js:24654:40
loadModuleImplementation
AppEntry.bundle?platform=android&dev=true&minify=false&hot=false&assetPlugin=%2FUsers%2Flwpro2%2FProjects%2FRoomChat%2Fnode_modules%2Fexpo%2Ftools%2FhashAssetFiles.js:276:14

AppEntry.bundle?platform=android&dev=true&minify=false&hot=false&assetPlugin=%2FUsers%2Flwpro2%2FProjects%2FRoomChat%2Fnode_modules%2Fexpo%2Ftools%2FhashAssetFiles.js:22473:14
loadModuleImplementation
AppEntry.bundle?platform=android&dev=true&minify=false&hot=false&assetPlugin=%2FUsers%2Flwpro2%2FProjects%2FRoomChat%2Fnode_modules%2Fexpo%2Ftools%2FhashAssetFiles.js:276:14
guardedLoadModule
AppEntry.bundle?platform=android&dev=true&minify=false&hot=false&assetPlugin=%2FUsers%2Flwpro2%2FProjects%2FRoomChat%2Fnode_modules%2Fexpo%2Ftools%2FhashAssetFiles.js:152:47
global code
AppEntry.bundle?platform=android&dev=true&minify=false&hot=false&assetPlugin=%2FUsers%2Flwpro2%2FProjects%2FRoomChat%2Fnode_modules%2Fexpo%2Ftools%2FhashAssetFiles.js:304445:4

few steps to resolve these:


1. update the expo and react native to updated and matching versions
2. remove all node_modules
3. re-run npm install
4. kill the simulator (this would make sure the expo start update the expo client)
5. expo start -c

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s